contador Histats.co

icrosoft ha advertido a los usuarios de Windows que deben instalar un parche de seguridad “de emergencia”. Se trata de un caso de actualización out-of-band; es decir aquellas que se publican fuera de la periodicidad habitual, algo que en el caso de Microsoft significa el segundo martes de cada mes. El gigante de software hizo público en un mensaje que un fallo de seguridad en algunas versiones de Internet Explorer podría permitir a un atacante ejecutar un código malicioso de forma remota en sus dispositivos.

Así, un usuario podría verse infectado al visitar una página web en la que hackers hubieran introducido dicho código malicioso, o bien siendo manipulados para que hagan clic en un enlace de correo electrónico. “Un atacante que explote con éxito la vulnerabilidad podría tomar el control de un sistema afectado”, ha advertido la compañía. Microsoft afirmó también que tenían confirmación de que la vulnerabilidad estaba siendo activamente explotada, aunque los detalles de la brecha no se habían hecho públicos hasta ahora.

Windows e Internet Explorer

Más del 7% de todos los usuarios de navegadores estarían ejecutando versiones afectadas de Internet Explorer 9, 10 y 11, según datos recientes. En cuanto al sistema operativo, todas las versiones soportadas de Windows estarían afectadas, incluyendo Windows 7, Windows 8.1 y Windows 10, así como varios Windows Server.

La mayoría de los usuarios pueden instalar el parche a través de Windows Update. Microsoft también ha publicado una corrección para el escáner de malware que incorpora su Windows Defender, un exploit que, en caso de ataque, podría haber desencadenado una denegación de servicio que hubiera provocado que la aplicación no funcionara. La empresa dijo que los usuarios no necesitaban realizar ninguna acción adicional para solucionar el error en Windows Defender.

Es raro, aunque no inaudito, que Microsoft publique parches de seguridad de emergencia fuera de su ciclo típico de actualizaciones mensuales. Más allá del llamado Patch Tuesday, se publican las correcciones para vulnerabilidades significativas bajo explotación activa tan pronto como estén disponibles. Las autoridades norteamericanas emitieron su propio aviso instando a los usuarios afectados a instalar los parches cuanto antes.

Vulnerabilidad

En concreto, los expertos de Microsoft descubrieron que existe una vulnerabilidad de ejecución remota de código en la manera en la que el motor de scripting gestiona los objetos de la memoria en el Internet Explorer. Dicha vulnerabilidad podría corromper la memoria de tal manera que un atacante sería capaz de ejecutar un código arbitrario en el contexto del usuario. Un atacante que consiga explotar la vulnerabilidad podría obtener los mismos derechos de usuario que el mismo propietario.

Además, si dicho usuario posee derechos de administrador, el atacante que haya explotado con éxito la vulnerabilidad podría tomar el control de un sistema afectado. Eso permitiría instalar programas, ver, cambiar o eliminar datos, o crear nuevas cuentas con todos los derechos de usuario.

En un escenario de ataque basado en la web, esto se produciría cuando un atacante crease un sitio web especialmente diseñado para explotar la vulnerabilidad a través de Internet Explorer y luego consiga que la víctima lo visite, por ejemplo enviando un correo electrónico. La actualización de seguridad resuelve la vulnerabilidad modificando el motor de secuencias de comandos que maneja los objetos de la memoria.

FUENTE: https://www.pandasecurity.com/spain/mediacenter/noticias/parche-seguridad-microsoft/